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Thank you for purchasing our product. If there is any question or request, please do not hesitate to
contact the dealer.

This manual is applicable to VSPlayer for Windows.

This manual may contain several technically inaccurate points or printing errors, and the content is
subject to change without notice. The updates will be added into the new version of this manual.
We will readily improve or update the products or procedures described in the manual.
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Chapter 1 Introduction

1.1 Description

VSPlayer is a free media player designed for Windows. It provides an intuitive, easy to use interface
to play digital media file, and supports a myriad of audio and video formats. In addition, it offers
many advanced features, is extremely customizable, and is available in both Chinese and English.

1.2 Main Features

® Support various record files of encoder products, including:

DS-9000/9100, 8100/7100, 8000/7000/7300 series network video record;
DS-6500/6100/6000 series video server;

DS-6600 series video encoder server;

DS-4200/4100/4000 series video/audio compression card;
Network camera/network speed dome;

® Support various file formats, including:

Hikvision H.264; Standard H.264, Standard MPEGA4.
Support file list play;

Support right-click menu;

Support various play modes and image quality parameter configuration;
Support multi-language;

Support continuous capture mode;

Support file information check;

Support multi-screen display;

Support Windows XP/2000/Vista/Win7 OS;

Support file cut/merge/convert;

Support multiple clock precision selection;

Support control screen resolution selection;

Support watermark;

Support zone magnify;

Support location by time/frame num;

Support synchronous playback;

Support reverse playback;

Support intelligent information display;



1.3 Installing VSPlayer

Steps:

1: Download the VSPlayer package for Windows from the Hikvision website which is in the dmg format.
2: Mount the dmg file to the Windows system and open it by double-clicking the file.

3: Right-click the installation file and select copy to copy it to the local disk.

4: Double-click the installation file to run the VSPlayer.

1.4 Uninstalling VSPlayer

Drag the VSPlayer application to your trash can to get it removed.



Chapter 2 Overview

2.1 VSPlayer Overview

Double click the shortcut icon on the desktop to run the software.

@& VSPlayer

1 B

2
VSPlayer
3
4
5
Figure 2-1 Interface Overview
Table 2-1 Interface Overview
NAME DESCRIPTION
1 Shortcut key Full-Screen, Top display,Player Settings,Zone magnify
2 Play Interface Display the video.
3 Process Bar Display the play process.
4 Control Bar Play/pause the video, adjust the play speed and the volume.
5 Status Bar Display the information of the elapsed time, frame, etc.
6 Main menu Enter the main menu interface of the VSPlayer.
7 Playlist Collect the videos which are going to be displayed.
8 Tool Enable the capture and continuously capture function.
4 Control Bar Play/pause the video, adjust the play speed and the volume.
5 Main menu Enter the main menu interface of the VSPlayer.
6 Playlist Collect the videos which are going to be displayed.




7 Playlist Control Bar Add/delete file, empty the playlist, and set the play mode.
8 Tool Switch the language/Open the file/Enable the capture and
continuously capture function.

Click the playlist button,it display the list as below:

Function Description:

Add File

= Delete File

Clear the playlist

Select the play mode:Single Play,Playlist play,Repeat one,Repeat All

Close the playlist

Right click Menu
In the window display area click the right mouse button,as below

& VSPlayer
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D:\VSPlayer6.2.0\synl\cut_2.mp4

2.2 Function Description

Table 2-2  Function Description

ICON

MENU SUBMENU

File

Language

Simplified Chinese;English

Add Files




File Information

Exit

Play Play/Pause(Space)
Stop
Top Display » Always;Only Playing; Never
Play Control » Reverse Play;Locate; Frame Forward;
Frame Backward; Speed Up; Speed
Down
Play Mode » Single Play; Playlist Play; Repeat One;
Repeat All
View » Full Screen; Normal Size; Double Size;
Half Size; Quarter Size;
High Quality Display;
Watermark info;
Image Control;
Color Adjust;
IVS Info;
Sound » Volume Up; Volume Down;Mute;
Play window layout » 1 window ; 4 windows ; 9 windows ;
16 windows
Tools Capture
Continuous Capture
Cut
Merge
Convert
Part
Setting Play Settings (Please refer to the play
settings table below)
Help Hotkey
About
Table 2-3 Play Settings
MENU ITEMS SUBITEM OPTIONS
General Basic » Option » High Quality Display ; Deflash
Settings Play Optimization » | Efficiency Priority; Effect Priority
Throw B-Frame » Don’t Throw; Throw 1; Throw 2
Player Time » High Precision Timer; Low Precision
Timer
Hotkey/Mouse
Play Settings | Video Locate Time Locate; Frame Locate
Play Speed Speed Up; Speed Down
Picture Image Control Normal Resolution; Low Resolution




Settings Color Adjust Lightness; Hue; Contrast; Chromaticity

Tool Settings | Capture Save Path; Save Type

Continuous Capture Save Path; Save Type

2.3 Icon Introduction

Table 2-4 Icons Description

ICON DESCRIPTION

Play

Pause

Stop

Replay the file from the beginning;
Push the playing process directly to the end of the file.

Speed Up; Speed Down

Frame Forward; Frame Backward

Capture

Reverse Play

Synchronous Playback

Enable the volume; Mute; Volume Adjustment

Language switches

Add the files to the playlist

Hide/show the playlist

Capture; Continuous capture;Cut;Merge;Convert;Part




Chapter 3 Operations

3.1 File

Purpose:
You are able to open a file or check the file information from the Z#e menu, or you can exit the player by clicking

Exit.

3.1.1 Open a File

Steps:
1. Click the Fife menu, and select the Open Fife menu item. An Open File dialog box will appear.

2. Select the file or files you want to open, and select Open to start playing the selected files. See Figure 3-1.

Note:
An alternative is to drag the needed file directly to the play window, and the file will be played as well.

@5 vsPlayer

VSPlayer

Figure 3-1 Open a File

3.1.2 Check the File Information and Exit

® File Information:

There are two ways to check the file information:
o Click File, and go to File Information to check the related file information, including the file name, file type,

resolution, frame rate, time, file size, and file path, etc.



Right click on the play window, and go to File Information to check.
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Figure 3-2 File Information Check
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File Name: cut_2.mp4

[‘BasicInfo |Exta info

| File Type: P

| File size: 3.43MB

| File Length: 00:00:39
Resolution: 704* 576

File Path: D:\VsPlayers, 2.0\syn T\ut_2.mp4

Mmo -

(=]

Playing \WS! ynlicut 2 mp4 140/998 00:00:05/00:00:39

Figure 3-3 File Information(Basic)

® Exit

Instead of clicking n on the top right corner, you can also go to F#e, and go to Exi to stop running the
player.



3.2 Play

Purpose:
You can change the play-related settings under ZZgpy menu, including Play/Pause/Stop, Top Display, Play Control,
Play Mode, Player Size, Sound and Language, ctc.

3.2.1 Play/Pause/Stop

You have several ways to pause/stop a playing file.

e Click E on the top right corner, go to Play tab, and then select Play/Pause or Stop;,
e Right click on the play window, go to Play/Pause/Stop;

(m
. Clickn, n or to play/pause or stop the file.

3.2.2 Top Display

Purpose:
If there are several windows opened on the desktop at the same time, the Zop Display will makes the VSPlayer
window appear at the top of the others, so that you can easily access it.

Steps:
1. Click E on the top right corner, go to Play, and then select 7op Display.

2. Setthe Top Display to AMwaps to enable the function, or select Meverif you don’t want to top display the
video.

rie »
Play/Fauze
Tool r Stop
Setting F
Help L4

Tap Display 3
Orly Flaying

Flay Control 4
v Hever
Flay Mode L4 A —
View |
Sound |

Flay window layout F

Figure 3-4 Top Display

Note: you can also enable the Top Display via right click on the play window, and go to Zap Display tab, then set it
to Always or Never.



3.2.3 Play Control

Purpose:
Play control helps you to locate the file to a specific timing or frame. And you can also adjust the file process by

frame or speed.

3.2.3.1 Reverse Play

Steps:
1. Click E on the top right corner, and go to Reverse Play.

2. Select Play Control, and go to Reverse Play.

3. Reverse Play the video you can use . to reverse play the video.

File 4

Taol 4 Stop

Setting *
£ Top Dizplay Ll

Help 4

Flay Control Reverze Flay
Flay Maode

Locate
Frame Forward
Frame Baclward
Speed Up
Speed Dawn

View 4
Sound L4
Flay window layout #

Figure 3-5 Reverse Display

Nofte:
An alternative is to right click on the play window, and go to Play->Play Control->Reverse Play

3.2.3.2 Locate the File

Steps:
4. Click E on the top right corner, and go to Play.

5. Select Play Control, and go to Locate.

6. Input the timing or the frame you want the file to start, and then click Locate to get it located.



Locate
Basic

HotHKey

File ko '
Taal k| Stop
2 Image Control
Setting P - P
Help » Top Dizplay i Color Adjust
Reverze Flay
Flay Made L4 Locate
Capture
: < Frame Forward
View Tt B s Continuous Capture
Sound b S
ae

Speed Down

Figure 3-6 Locate the File

Note:
An alternative is to right click on the play window, and go to Play->Play Control->Locate.

3.2.3.3 Frame Forward/Frame Backward

Video frame is one of the many still (or nearly so) images which compose the complete moving picture. When the
moving picture is displayed, each frame is flashed on a screen for a short time and then immediately replaced by

the next one.
Frame forward/frame backward provides you to control the video process by frame. The video will be paused at the

second you select Frame Forward/Frame Backward, and you can check the video out frame by frame.

Steps:
1. Click E on the top right corner, and go to Play.

2. Select Play Control, and go to Frame Forward/Frame Backward.

3. Forward/backward the video by clicking the Frame Forward/Frame Backward again. Or you can use the

hotkey of <——, or . - to frame forward/backward the video.

i rite
Flay/Fausze
Tool 4 Stop
Setting ¥
Help 4

Top Display 4

Flay Control Rewerze Flay

Flay Made Locate

Frame Forward
Frame Baclward
Speed Up
Speed Down

View
Sound r
Flay windew Llayout F




Figure 3-7 Frame Forward/Frame Backward

3.2.3.4 Speed Up/ Speed Down

The VSPlayer provides four ways for you to speed up/speed down the video play.
X2, x4, x8, and x 16 are selectable for speed up, speed/2, speed/4, speed/8, and speed/16 are selectable for speed
down.

® C(Click E on the top right corner, and go to Play-> Play Control -> Speed Up/Speed Down.

® Right click on the play window, and click Play Control-> Speed Up/Speed Down.

® C(Click . . to speed up or speed down.

® Set the play speed from the Play Settings, please refer to the figure below.

Player Setting @]

Basic

Hotkey
(%) Speed Up (O Speed Down
Video Locate
3

Image Control

Color Adjust

Capture

Continuous Capture

Figure 3-8 Set the Play Speed From Player Settings

3.2.4 Play Mode

The playlist supports several playback modes: Single Play, Playlist Play, Repeat One, and Repeat All.

Single Play plays the selected file and stops when the file finish.

Playlist Play plays the files according to the sequence in the playlist.
Repeat One keeps play the current selected file until another file is forced.
Repeat All loop plays the playlist until another command is received.

You can follow the ways below to set your desired play mode.



® Click E on the top right corner, and go to Play-> Play Mode -> Single Play/Playlist Play/Repeat
One/and Repeat All

@® Right click on the play window, and go to Play Mode to select.

-+
® C(Click . on the lower right corner, and select the play mode.

rite IR

Taoal L4 Stop

Setting P |
Top Dizpla L4

Hely i p Dizplay |

Flay Contraol |
Flay Mode Single Flay

v Playlizt Flay
Single Rapaat
Flaylist Repeat

View

Sound

O i,
=5

Flay window layout

Figure 3-9 Play Mode

3.2.5 View

Purpose:

From the Plew tab, you are able to set the window size, control the image quality and adjust the image color.
Window Size:

The VSPlayer provides several window sizes for better viewing experience. You can select from Full Screen,
Quarter Size, Half Size, Normal Size, Double Size, and Fixed Size according to your own preference.

Notes:

The window size of the VSPlayer is self-adaptive to the file resolution, which means the window size may change
according to the different resolution, however, if fixed size is selected, the window remain the same size even
different files are played.

You can follow the ways below to select your desired window size.

® Click E on the top right corner, and go to Play-> View-> Full Screen/Normal Size/Double Size/Half

Size/Quarter Size.
@ Right click on the play window, and go to Wiewto select.

High Quality Display(Coming Soon):

High Quality Display is preferred when only one-window show to guarantee the image quality.

Watermark Info(Coming Soon):

Digital watermarking (Digital Watermarking) technology is the number of identification information (i.e., digital
watermark) directly into digital media (including multimedia, documents, etc.) or indirect representation (modify
specific regions of the structure), and does not affect the value of the original carrier, is not easy to be detected
and modify again. But can be production of recognition and identification. Through these hidden in the carrier of



information, can confirm the content creators, buyers, or to send secret information to determine whether the

carrier has been tampered with and so on purpose.

( x

Mac 00:40:48:68:af:81
DeviceSN 405337265

Chan 1

GTime 2011-11-1 08:58:48

Devicelnfo 1

DeviceType 31

Figure 3-10 Watermark Info

Image Control (Coming Soon):

Normal Resolution is preferred when the usage of the CPU is low to guarantee the image quality, however, the
Low Resolution is preferred if the usage of the CPU is too high to guarantee the image fluency.

Color Adjust (Coming Soon):

You are able to adjust the Lightness, Hue, Contrast, and Chromaticity of the image from Color Adjust option.
Lightness refers to the brightness of the image.

Hue refers to the quality of a color as determined by its dominant wavelength.

Contrast refers to the perceptual effect of the juxtaposition of very different colors.

Chromaticity refers to an objective speciation of the quality of the color regardless of its luminance.

IVS Info:Intelligent Video System info.

® Click E on the top right corner, and go to Play-> View->/VS Info

@® Right click on the play window, and go to Wewto select.

File 2 !
Tasl F Stop

Setting P
= Top Di=rlay v

Help ¥

Play Control 3
Play Mode r

Sound L4 Hormal Size

Double Size
Helf Size

Flay window layout P

Quarter Size

<

High Quality Display
Watermark Info

TImage Control
Coler Adjust

Figure 3-11 IVS Info
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Figure 3-12 IVS Info(normal)

G o

2011F01 H2?7 0 EHAIT JA:41:03

Camera 01

B =]

D:VSPlayer6 2. 0IVS.mp4 805/2953 00:00:32/00:01:58

Figure 3-13 IVS Info

3.2.6 Sound

Purpose:
From the Soundtab, you are able to set the sound volume or mute.
You can follow the ways below to set your desired sound volume.

® Click E on the top right corner, and go to Play-> Sound -> Volume up /Volume down/Mute

@® Right click on the play window, and go to Sownd to select.

® C(Click _ on the play control bar list, and select the sound volume.



File L4 .
Tool L4 Stop

S Top Display 4
Help L4
Flay Contraol 4
Flay Mode L4

3

¥iew

Play window layout P Yolume Down
Mute

Figure 3-14 Sound

3.2.7 Play window layout

Purpose:
From the Play window layout tab, you are able to set the window numbers.
You can follow the ways below to set your desired sound volume.
® Click E on the top right corner, and go to Play-> Play window layout-> 1 window/4 windows/9
windows/ 16 windows

® RIght click on the play window, and go to Play window layout to set.

| File >_'
Taal 4 Stop
Setting P
& Top Dizplay 4

Help L4
Flay Contral 1
Flay Mode L4

¥iew

4 window
9 window

16 window

Figure 3-15 Play window layout
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Figure 3-16 Play 4-window layout

Notes:

The number of the player window can be in one, four, nine, sixteen, each window can independently play the file.
When switching windows, close all the playing file in the current window. Need to darg the file by left mouse drag
to the display playback window can be played.

The current version of the player supports multiple files simultaneously preview.

3.2.8 Synchronous Playback

Synchronous Playback
Purpose:
You can Synchronized playback the files in the file list.. Please refer to the pictures below.

® C(Click . on the play control bar list.

® Add the file to the file list.

In Synchronous mode, press Shift or Ctrl select the files in the playlists, and then click the n
synchronized playback multiple files.
As belows,in each window the OSD time is not the same



Figure 3-17 Synchronized playback

@9 vSPlayer

HEIBE

Camera 63

Figure 3-18 Synchronized playback(OSD same)



Figure 3-19 Synchronized playback fail

Synchronous Playback Control

_Can be used to accurately synchronized playback file time.

&) VSPlayer

Camcra 83 Cancra 03

Cancra 63 ‘ Cancra 03

Figure 3-20 Synchronized playback (before)
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Figure 3-21 Synchronized playback locate(after)

Drag the button . can locate the synchronized time.

@5 VsPlayer
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Figure 3-22 Synchronized playback locate



3.3 Tools

Purpose:

Under the Zools menu, you are able to capture the picture by using the Capture or Continuous Capture or Cut file
or Merge file or Convert file or Part .

Capture allows you to snapshot the image and save it at the specific path.

Continuous Capture snapshots the image continuously at a speed of one picture per second, and save them at the
specific path.

There are three ways for you to capture the image.

® Click E on the top right corner, and go to 7ools-> Capture/Continuous Capture.

@® Right click on the play window, and go to Capture or Continuous Capture.

® Click . on the play control bar list to capture the picture.

® Click H on the low right corner, and select Capture or Continuous Capture.

The captured file can be saved at the specific path in different format (BMP or JPEG) by the configuration in the
Player Settings. Please refer to the figure below.

Player Setting @

Capture
Easic P
HotKey S P -C ........................... ; [m]
Play Set Save Type: [emp v
Video Locate b
Speed
Image Cortrol
Color Adjust
Capture
Continuous Capture

Figure 3-23 Capture

Player Setting @

Basic

Hotkey SavePath:  [C
oy kg Save Type BMP v
Video Locate
Speed
Image Contral
Color Adjust

Capture

Cancel




Figure 3-24 Continuous Capture

3.3.1 Cut

Purpose:
You can cut the part of the file . Please refer to the pictures below.

® Click E on the top right corner, and go to 7oo/s-> Cut.

® C(Click H on the low right corner, and select Cut.

o
Setting F Contimmons Capture
bl :

Help

.
9 chl_main Merze

Conwert

Fart

Figure 3-25 Cut
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Figure 3-26 Cut File
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Figure 3-27 Cut File(Preview)

Figure 3-29 Cut File Success

3.3.2 Merge

Purpose:
You can merge the files of the merge file list . Please refer to the pictures below.

® C(Click E on the top right corner, and go to 7oo/s-> Merge.

® Click H on the low right corner, and select Merge.

File 4
Flay i |}
e

Setting F Continmous Capture
Help 3

Cut

Merze

Conwert

Part

Figure 3-30 Merge File



AddFile | ’ Delete File

File Mame File Time(s)
D:WSPlayers, 2,.0\synilcut_1.mp4 27
D:\WsPlayers, 2.0%syn1\cut_2.mp4 39
D:\WsPlayers, 2.0%syn1icut_1.mp4 27
D: \WsPlayers, 2.0\syn1icut_all.mp4 63
D:\WSPlayers, 2.0%syn111.mp4 155

Qutput Setting
Tar File: |D:\sPlayers.2.0\syn1122.mp4 | [ erowse
| Ok | [ Cancel

Figure 3-31 Merge File(Add File)

Add File ] l Delete File

File Mame File Time(S)
D:\WSPlayer6. 2.0%syn1\cut_1.mp4 27
D:\WSPlayers. 2.0\syn 1icut_2.mp4 39
D:\WSPlayers. 2.0%syn 1icut_1.mp4 I
D:\WSPlayers, 2.0%syn 1\cut_all.mp4 63
D:\WSPlayerg, 2.0%syn1\11.mp4 155

Qutput Setting
Tar File: D:WSPlayers, 2.0\syn1122.mp4 | [ Erowse ]
|
[ LT ]

Figure 3-32 Merging

¥Y5Player

L] Success to merge!
L

Figure 3-33 Merge Success



Add File ] [ Delete File

File Name File Time(3)
D:\TestFile\TestFile \4CIFntsc. mp4 360
D:\TestFile\90004ch07_20090413095457. mp4 32

¥5Player

] D:4\TestFile 9000%h0T_20090413095457. mpdean not be merged!
L)

Output Setting

Tar File: D:\TestFile\9000\des.mp4 | [ Browse

[ oK ] [ Cancel

Figure 3-34 Merge Fail
Notes:
File merge only support the file system format and encoding format is same.

3.3.3 Convert

Purpose:
You can convert the file to the file of other system format and other encode format(Only support AVI format

currently version) . Please refer to the pictures below.

® C(Click E on the top right corner, and go to 7oo/s-> Convert.

® Click H on the low right corner, and select Convert.

[

A¥I Converzion

ResFie: |Di\TestFie\90001172.8.104.64 01 20090622 | [ Browse |
. |

Tar File: |D:\TestFile\3000\des v | [ prowse |

Figure 3-35 Convert File




¥5Player

j ]
' Success to Conwert! |
. I
1
| Browse

100% Convert Cancel

Figure 3-36 Convert File Success

ResFile: |D:iTes

-
Tar File: | D: \Tes

3.3.4 Part

Purpose:
You can zone magnify the part of the display on the display window screen.. Please refer to the pictures below.

® C(Click E on the top right corner, and go to 7oo/s-> Part.
® Click = on the low right corner, and select Part.

® C(Click - on the left corner.

@5 VSPlayer - s

. Hrle + -7 3 x

e T 2009_PAL_6_ch1_main_AV|
2009E11H14H FH7S 17:52:38

r' - F_17_P_EBR_1024

nct only be seesing the fantastic largignepe 01

Mmae

Playing  9000\81_KY2009_PAL_6_chl_main AV_2CIF_1F_17_P_CBR_1024_20091114.  13/28 00:00:12/00:0026

Figure 3-37 Zone Magnify(normal)



= - 0OXx

+-% 3 %
181_KY2009_PAL 6 chl_main_AV]

{145 EHA7< 17:52:38

- F_17_P_CBR_1024

~e

Panse 900081 KY2009 PAL 6 chl_main AV 2CIF_IF_17 P_CBR. 1024 20091114  13/28 00:00:12/00:0026

Figure 3-38 Zone Magnify(magnify)
Notes:
Press and hold the left mouse button, slide the mouse wheel zoom in on the current region. Drag the display
window select magnify zone.



3.4 Settings

Purpose:
You can configure general settings, Play Settings, Picture Settings, and Tool Settings from the Play Setting interface.

BPlayer Setting @

Please refer to the pictures below.

Basic

HotKey High Guality Display
Deflash
Video Locate S
Spead () Eiciency Friority (&) Effect Priority
Throw B-Frame
triaga Coriral (=) Dont Throw ) Throw 1
Color Adjust () Throw 2

ayer Timer

[
arhre () High Precision Timer O Low Precision Timer

Continuous Capture

i ok

5 Cancel

Figure 3-39 Player Settings

3.4.1 General Settings

Basic

e Option (Coming Soon)
Check High Quality Display and Deflash are configurable.
If Check High Quality Display is selected, the CPU usage is higher, and the image quality is better. If there are
several VSPlayers playing together, you can uncheck the check box to lower the CPU usage.
If there is some noise in the still image, the video presents a slight flash or refresh. If the Deflash function is
enabled, the flash or refresh will be eliminated or improved, and the noise will be reduced as well.
e Play Optimization (Coming Soon)
Efficiency Priority ensure the fluency is prior during the playing
Effect Priority ensures the effect of the image is prior during the playing.
e Throw B-Frame
Throw B-Frame is used to ensure the file fluency. Don’t Throw, Throw 1 and Throw 2 are selectable. Throw 1
and Throw 2 are preferred if the fluency is not so satisfied.
e Player Timer
High Precision and Low Precision arc selectable. High precision is used when the image quality is prior. And the

Low precision is used when the file fluency is prior.

Hotkey/Mouse

Hotkeys are sometimes referred to as shortcut keys because of their ability to easily trigger an action. The VSPlayer

provides many hotkeys for better operation. Please refer to the figure below.



Player Setting @

Het Ky
Basic R
Pty Selfiag Stop ?’GH‘_S |
Video Locate Frame Backward Leﬂ
Speed Frame Forward
Volume Up
Volume Down
Image Contral
Go to Start
Color Adjust
Goto End
Add files
Capture
Continuous Capture

Figure 3-40 Hotkeys

3.4.2 Play Settings

Please refer to Chapter 0 Locate the file and Chapter 3.2.3.4 Speed Up/ Speed Down.

3.4.3 Picture Settings

Please refer to the Image Control and Color Adjust sections in Chapter 3.2.3.6 View.

3.4.4 Tool Settings

Please refer to Chapter 3.3 1ools.



3.5 Help

Purpose:

You can check the software version and hotkeys from the Help menu.
® About

The current software version will be listed if you go to Hedp, and click About.
® Hotkeys

Please refer to Hotkey/Mouse section in chapter 3.4.1 General Settings.
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